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Edjob

When your applications are updated, changes in software often require that new parameters or
blocks be added or removed from your existing job files. The Edjob utility is a convenient tool that
will bring your job files up to date when new software is released. Edjob is free with your purchase
of any product that uses job files.

Earlier software versions

Before editing a job file, Edjob checks the General block to determine the job-file type (product) and
version number. If necessary, Edjob can bring a file up to date from earlier versions.

If the job file already has been updated, Edjob will send you a message, but it will not update the
file. In this way, you are protected from double updating.

Where is Edjob installed?

There is no special, separate procedure for installing Edjob. When you install a software release, we
place the latest version of Edjob in the adm subdirectory of the installation location (e.g.
...ss\adm). We also place an update script in the appropriate software subdirectory that tells
Edjob which new software features should be added and which obsolete features should be
removed from your job files.

Use the Edjob program and scripts exactly as they are installed. If you move or copy these files, we
can't keep them up to date. There’s a chance that an obsolete Edjob or script might be left in your
system. And that could cause you trouble at the next release.
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Edjob update scripts

Edjob follows a script that we provide. Each time we release new software—except minor revisions—
we include a new script file. This script tells Edjob what changes to make. There are separate scripts
for each product.

Usually, Edjob should be able to find the update script by itself, and you won’t need to specify the
file when you set up Edjob. Sometimes we publish a special, temporary, or patch script. When you
are instructed to use a script name different from those listed below, then you need to include its
full path and file name in your setup.

NOTE Edjob will be able to find the update script only if you have correctly set up the envir-
onmental variable PW_PATH. Refer to the System Administrator Guide for instructions.

Update-script file names

When you name job files, be sure to use the file name extensions listed below. If you use other
extensions, Edjob will not be able to update your jobs.These update script files are located in the
...\ss\pst (Windows) or .../ss/presort (UNIX) directory.

By default, Edjob backs up each job file before updating it. The backup has the same name as the
job file, but with a different extension, as listed below.

Program Update script file Job-file extension Backup extension

Label Studio pwlsjob.upd .lsj .lid

Presort pwpstjob.upd .pst .ped

ZipCount pwzctjob.upd .zct .zed

Design File Edjob Script Design extension Backup extension

General (update for
all design files)

pwdfgjob.upd .dfg .ged

Address pwdfgjob.upd .dfa .hed

Sack pwdfgjob.upd .dfs .ied
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Tray pwdfgjob.upd .dft .jed

Pallet pwdfgjob.upd .dfp .ked
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Updating your job files

Follow these steps to update your job files.

1. Specify the job file(s) you want Edjob to update.

2. Tell Edjob which options to use. Choose Options > Edjob Setup.

3. Run Edjob. Click Run on the Select Job File window.

Setting up Edjob

Follow these steps to update your job files.

1. Specify the job file(s) you want Edjob to update. When you start Edjob, it automatically displays
the Select Job File window. (If you don't see this window, choose File > Select Job File to dis-
play it.) Use the Select Job File window to specify the path of a job file. Enter the path and
name of a file in the Job File text box. You can use the browse button to locate the file, if you
don't want to type in the path (or don't remember the path).

If you wish, you can use wildcard characters to update more than one file at a time. For
example, to update all of the Presort job files in a particular directory, you could specify *.pst
for the file name.

You can also update multiple files by using a text editor (such as Notepad) to create a simple
text file that contains a list of job files or wildcards. Instruct Edjob to use this list by clicking the
Job File Is A Job List File check box, and including the path and name of the job list file in the
Job File text box.

2. Tell Edjob which options to use. Choose Options > Edjob Setup.

3. Run Edjob. Open the Select Job File window (if it isn't already open) by selecting File > Select
Job File. Run Edjob by clicking the Run button on the Select Job File window.

Specifying options

Follow these steps to update your job files.

1. Specify the job file(s) you want Edjob to update.

2. Tell Edjob which options to use. Choose Options > Edjob Setup to specify any options you want
Edjob to use when it updates your job file(s). Edjob displays a window that enables you to
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specify these options:

l Remove excess blank lines so that the maximum number of contiguous blank lines
(between blocks) will be x (1-9). Click the Remove Excess Blank Lines check box and spe-
cify the number of blank lines you want between blocks.

l Suppress prompts for confirmations that normally appear before each job file is edited by
clicking the Suppress Confirmation Prompts check box.

l Search for and update all job files found within all subdirectories of the path you specify by
clicking the Search All Subdirectories check box.

l Choose not to back up each job file before Edjob updates it by selecting the Do NOT
Backup Job Files check box. Normally, Edjob backs up each job file before updating it (for
example, jobfile.pst is backed up to jobfile.ped).

l Choose to see progress messages on the screen (or not) by clicking the None, Verbose, or
Very Verbose button in the Messages box.

l Log errors (job files found but not updated) by clicking the Error Log File tab and specifying
the path and file name where you want Edjob to store the log files. Normal progress mes-
sages still go to the screen. This option is handy for overnight processing, because Edjob
does not stop on errors. The log file contains one line per job file found. Even if there is no
error, the file name is logged—so the log is a handy way to verify that a particular job was
updated.

l Sometimes we publish a special patch script, and then you need to include a full path name
so Edjob can find the update script file (click the Script File tab). Usually, Edjob should be
able to find the update script by itself, so you won’t need to enter the path and name of the
script file.

3. Run Edjob. Choose File > Run Edjob.

Running Edjob

Follow these steps to update your job files.

1. Specify the job file(s) you want Edjob to update.

2. Tell Edjob which options to use. Choose Options > Edjob Setup.

3. Run Edjob.



Edjob User Guide | 6

4. Open the Select Job File window (if it isn't already open) by selecting File > Select Job File.

5. Run Edjob by clicking the Run button on the Select Job File window. Edjob opens a DOS win-
dow and updates your job file(s). You may see prompts and progress messages displayed on
your monitor, depending on how you set up Edjob.

6. When Edjob has completed the update(s), the DOS window disappears and the error log file
opens automatically (if you chose this option when you set up Edjob). You can then change the
job file path and name and run Edjob again, or close the Edjob window.
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Running Edjob from the command line

Edjob is a simple utility. It does not present any menus or displays. You control the program by
adding options to your Edjob command line.

For your convenience, these command-line options are also listed in our Quick Reference.

DOS or Windows

edjob_ss [/cnsbx] [/v | /V | /vv] [/e:error_file] [script.upd]
jobfile

UNIX

edjob_ss [-cnsbx] [-v | -V | -vv] [-e:error_file] [script.upd]
jobfile

Command line elements

Command Description

edjob_ss If the ADM directory is in your PATH setup, your operating system should be able
to find the Edjob program.

Otherwise, you may need to type out the full path to the executable program file
(edjob_ss or edjob_ss.exe).

bx Remove excess blank lines so that the maximum number of contiguous blank
lines (between blocks) will be x (1-9).

c Suppress the prompt for confirmation that normally appears before each job file is
edited.

NOTE When using a list file or wildcard, include the c switch in your com-
mand line.
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e Log errors in the log file. Normal progress messages still go to the screen (stand-
ard out). This option is handy for overnight processing, because Edjob does not
stop on errors. The log file contains one line per job file found. Even if there is no
error, the file name is logged, so the log is a handy way to verify that a particular
job was updated.

s Recursively search for job files in all subdirectories.

n No backup. Normally, Edjob backs up each job file before updating it (for example,
jobfile.pst is backed up to jobfile.ped). If you don't feel that this backup
is necessary or you can't spare the disk space, add the n option to suppress the
backup.

We recommend allowing Edjob to create this backup file.

script.upd Update script. Usually, Edjob can find the update script by itself, and you don't
need to include the file in your command line. Sometimes we publish a special
patch script, and then you need to include a full path.

v | V or vv Produce verbose (v) progress messages, or Very Verbose (V or vv) messages.

jobfile There are three ways to tell Edjob which job files you want updated:

l Type the full name (with path, if necessary) of one job file.

l Type a wildcard (for example, *.pst.) On UNIX, enclose the wildcard in
quotes (".pst") to prevent the shell from expanding the wildcard. Edjob
prefers to do this on its own. See Sample command lines for examples.

l Use your text editor to create a simple text file that contains a list of job files or
wildcards. Instruct Edjob to work from that list by typing the @ symbol on your
Edjob command line. See Sample command lines for examples.

Sample command lines

Here are some sample command lines for DOS/Windows and UNIX.

DOS or Windows command prompt

EXAMPLE The following command reads job-file names from a list called (pst_jobs.txt),
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and logs errors in a file called (update.log). Edjob makes a backup copy (with the extension
.ped) just before updating each Presort job file. Edjob suppresses the prompt for confirmation.

C:\ss\adm\edjob_ss /c /e:update.log @C:\work\pst_jobs.txt

EXAMPLE In this example, Edjob begins working in the directory called C:\work\jobs.
Edjob searches this directory and all sub-directories for Presort job files. Edjob prompts for con-
firmation before editing each job file that it finds, and it produces normal messages. Edjob
makes a backup copy (with the extension .ped) just before updating each job file.

C:\ss\adm\edjob_ss /s C:\work\jobs\*.pst

EXAMPLE Here's an example with the prompt for confirmation suppressed; no backup copies
are made.

C:\ss\adm\edjob_ss /cns C:\work\jobs\*.pst

NOTE You may omit C:\ss\adm\ if you have already defined the path.

UNIX

EXAMPLE The following command suppresses the normal confirmation and backup. Edjob
starts in Barbara's user directory and looks for Presort jobs in all subdirectories below it. Notice
the wildcard is enclosed in quotes.

/usr/ss/adm/edjob_ss -cns "/usr/barb/Presort_jobs/*.pst"

EXAMPLE The following command updates job files following the list in the file joblist. Edjob
does not prompt for confirmation, but does produce verbose messages. Where excess blank
lines are found, they are trimmed to two lines.

/usr/ss/adm/edjob_ss -cvb2 @joblist

NOTE You may omit /usr/ss/adm/ if you have already defined the path.
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Additional Resources

The following resources are available to help you with your software.

Documentation Updates Available Online

Presort documentation is updated on a regular basis and available in PDF format via the
BCC Software Customer Portal. Documents are posted in the Manuals & Quick Guides ⇨ section of
the portal—except for release notes, which are available in the Presort section of the Product Down-
loads ⇨ page.

You can access the most current versions of Label Studio documentation from the following links:

l Label Studio User Guide ⇨

l Label Studio Inkjet Reference ⇨

l Label Studio Release Notes ⇨

l System Administrator Guide ⇨

l Edjob User Guide ⇨

l Quick Reference for Views and Job Files ⇨

l Views Quick Start Guide ⇨

l Database Prep Guide ⇨

Knowledge Base

BCC Software offers tips, tricks, and best practices for using our products. Knowledge Base articles
can help empower both experts and new users.

l To learn more, visit the BCC Software Knowledge Base on the BCC Software Customer Portal ⇨.

How to Contact Support

l BCC Software Technical Support online:
https://bccsoftware.com/customer-center/customer-support/ ⇨

l Email: support@bccsoftware.com ⇨

https://portal.bccsoftware.com/Support/techManualsProduct.aspx?tm=presort
https://portal.bccsoftware.com/profile/productdownloads.aspx
https://portal.bccsoftware.com/profile/productdownloads.aspx
https://docs.satorisoftware.com/us/ls/docs/labelstudio_userguide_ss.pdf
https://docs.satorisoftware.com/us/ls/docs/labelstudio_inkjetref_ss.pdf
https://docs.satorisoftware.com/us/ls/rn/labelstudio_relnotes_ss.pdf
https://docs.satorisoftware.com/us/cmxp/docs/sysadminguide_ss.pdf
https://docs.satorisoftware.com/us/cmxp/docs/edjob_usersguide_ss.pdf
https://docs.satorisoftware.com/us/cmxp/docs/quickref_views_ss.pdf
https://docs.satorisoftware.com/us/cmxp/docs/views_quickstart_ss.pdf
https://docs.satorisoftware.com/us/cmxp/docs/databaseprep_ss.pdf
https://portal.bccsoftware.com/support/knowledgeBase.aspx
https://bccsoftware.com/customer-center/customer-support/
mailto:support@bccsoftware.com
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